A Google anunciou que vai finalizar o suporte do Google Play Services para algumas versões antigas do Android em breve, especificamente quando lançar a próxima atualização da loja.

google-play-store

A versão atual suporta a API nível 9, que é suportada no Android 2.3, mas quando a versão 10.2.0 do Google Play Services for lançada, a Google vai aumentar o nível minimo suportado pela API para 14, fazendo com que o Android 4.0.1 Ice Cream Sandwich, seja a versão mais antiga suportada.

Com isso, inevitavelmente, o suporte também vai se encerrar para o Android 3.0 Honeycomb. Em uma declaração a empresa se explicou dizendo:

A plataforma Gingerbread têm quase seis anos de idade. Muitos desenvolvedores do Android já descontinuou o suporte para Gingerbread em seus aplicativos. Isso os ajuda a construir melhores aplicações que fazem uso dos recursos mais recentes da plataforma Android. Para nós, a situação é a mesma. Ao fazer essa mudança, vamos ser capazes de fornecer um conjunto mais robusto de ferramentas para desenvolvedores do Android com maior velocidade.

thumb_550_gingerbread-googleOs últimos dados oficiais da Google, mostra que 1,3% dos aparelhos Android rodam Gingerbread, enquanto que menos de 0,1% estão no Android 3.0 Honeycomb, sendo assim, a companhia acredita que muitos desses dispositivos não estão sendo usados ativamente.

google-play-services-guidePara quem não conhece, o Google Play Services é uma plataforma que consiste de uma biblioteca para desenvolvedores, oferecendo todos os recursos necessários ao desenvolvedor que deseja criar aplicativos e disponibiliza-los na loja da Google. Em resumo, quem ainda possui um smartphone na versão 2.3 do Android vai deixar de receber atualizações de aplicativos.

A Google ainda não anunciou uma data exata para essas mudanças, mas diz que a versão 10.2.0 do serviço será lançado no início de 2017.